End users reach out because they’re receiving a quickbooks Error code: H202 message “This company file is on another computer, and QuickBooks needs some help connecting” when trying to switch to Multi-User Mode. Also technicians may get another error “Network Diagnostics: Failed” when they try to run the “Start Scan” feature in the QuickBooks Database Server Manager.
Root Cause: Port conflict between DNS and QuickBooks services
Environment: Quickbooks, DNS
Error: H202 “This company file is on another computer, and QuickBooks needs some help connecting” OR Network Diagnostics: Failed” Add an image link of the error
Fix: Disable both the DNS and QuickbooksDB3xx service. Re-enable the QuickbooksDB3xx service first and then the DNS one next. For the permanent fix, exclude the port the database manager is using from the dynamic ports pool by running: netsh int ipv4 add excludedportrange protocol=udp startport=xxxxx numberofports=1 (Swap the noted port number with the xxxxx in the command). More details below.
The Situation
A client calls in after a power outage and complains that they can’t sign in to quickbooks. I remote into their computer and see the H202 error as shown above and I immediately run to the server. I opened up the Database manager and made sure that the company file was there and then I clicked the start scan button, just for it to spit out an error message, “Network Diagnostics: Failed”
So, I checked that the server is able to ping the default gateway without any issues. I also tried to ping the server from the client’s computer and it pinged it without any issues. I also checked if there are any quickbooks updates available that we missed but they were all updated, I got confused, and like any other IT tech, I thought maybe when the power came back the server didn’t boot correctly so I decided to reboot the server but got the same results.
I turned off the windows firewall and rebooted again..same results. At this point I turned to the almighty google to see if there is anyone else who has encountered this issue. Here I found a reddit post(Thank GOD for the reddit community!!!!) from seven years ago under the sub reddit r/msp pointing out a dns server / qb database port conflict.
Under this post they mentioned that Quickbooks fixed the issue from the 2019 version(news flash it’s still an issue on even the 2020 version) but also added the port monitor window in the Quickbooks Database Manager, which helps to find the exact port that it’s picking up.
With this information, I found out that the DNS server and the Quickbooks DB Manager were indeed using the same port. Every time the server reboots, the DNS grabs the port before the Quickbooks Database Manager grabs it. This is why stopping the DNS service and starting the QuickbooksDB3xx service fixes the issue quickly, however, on the next reboot or power outage this issue is bound to reappear. Which is why the port exclusion after finding out what port is being used here is the permanent solution.
The Fix
There are two kinds of fixes you can run.
Temporary Fix
Open services(Press Windows + R, type service.msc and hit Enter) on the server running the quickbooks. Stop the DNS server service. Attempt to start the QuickBooksDB3x(The “x” after the 3 depends the version of quickbooks you’re running) service. Start the DNS Server service next. Run the company file scan again.
Note: The temporary fix will be undone the next time the server reboots.
Permanent Fix
Open the QuickBooks Database Manager program Select the Port Monitor tab Note the Port Number that the QuickBooks Database Manager is using. Swap the noted port number with the xxxxx in the command below. Stop the DNS Server service and the QuickBooks service.Please not that the exclusion must happen when the port in question is unbound. Also confirm the port type whether its UDP or TCP and that as the protocol, in the example below I used UDP Reserve the noted port by entering the following at a command prompt: netsh int ipv4 add excludedportrange protocol=udp startport=xxxxx numberofports=1 Start both services.
Prevention
To prevent this from happening, you would have to do everything in the permanent fix. This way you are guaranteed that the Quickbooks database will always pick up the port you excluded for it.